0

Slack event templates not picked up?

I tried opening a ticket with segment.com , but it wasn't super helpful, so trying here.

I've tried every way imaginable to configure event templates for my slack events to no avail. I've connected it up with my desired slack channel and I see all the events coming through, however they have the default "{{userId}} did {{event}}" template instead of my configured template for that event.

Even if my templates use no variables, the default treatment comes through, so it's like they are just being ignored completely. I've checked with the debugger, and I'm using the event names verbatim. So no idea what I could be doing wrong here.

For example:

event name (on the left):
temba.flow_broadcast

template (on the right):
{{userId}} just sent out a flow to {{properties.contacts}} contacts and {{properties.groups}} groups.

Here is an example of an like-named event from the debugger:

{
   "context":{
      "library":{
         "name":"analytics-python",
         "version":"unknown"
      },
      "source":"xxx"
   },
   "event":"temba.flow_broadcast",
   "properties":{
      "contacts":1,
      "groups":0,
      "value":1
   },
   "timestamp":"2017-01-12T20:13:45.982Z",
   "userId":"xxx@xxxx.com",
   "writeKey":"xxxxxx",
   "integrations":{

   },
   "receivedAt":"2017-01-12T20:13:46.299Z",
   "originalTimestamp":"2017-01-12T20:13:45.982506+00:00",
   "type":"track",
   "messageId":"api-xxxx"
}

Anybody else run into this or have an idea what might be up?

4replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Segment folks, am I running into a bug here? Can somebody have a look or point me in the right direction?

    Or maybe acknowledging that you're looking into it would be awesome.

    Thanks!

    Reply Upvote
  • Eric! This is a bug, and it appears an event name with a period, ".", causes the event's template to be missed. It's unclear which library contains the root issue, so I've filed an issue with our engineering team.


    Hold fast please! Or consider another naming convention if this is immediately critical for your team.

    Reply Upvote
  • Hi Wesley,

    Any word on a fix for this bug? We are still seeing the behavior on our end.

    Thanks,

    Eric

    Reply Upvote
  • I'm experiencing the exact same thing. Events send via the Slack destination event simulator work and have the template applied. Events from my actual source are not handled.

    Reply Upvote