UTM Tracking with Amplitude Cloud Mode

We have adwords utm tracking parameters enabled and I see the utm parameters in the segment debugger search string when landing on the page. I'm not seeing the parameters as traits for users in Amplitude though... I have send utm to amplitude setting enabled in the integration as well as track all pages to amplitude.

Is this because we are currently using cloud mode? If not, any other reason the utm parameters would not be associated with the user?  

Thank you!

9replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Dave Greenstein , Thanks for writing in!

    Segment will grab and parse  UTM properties found in the querystring to Amplitude if they are coming from the browser. 

    Would you mind opening a help ticket here so we can trade account- and implementation-specific information? You can add some sample data (call examples in which you see this behavior) when creating the ticket as we'll need to reproduce the issue to troubleshoot. 

    You can submit a ticket here. Looking forward to it!

    Reply Upvote
  • Reply Upvote
  • Dave Greenstein great! I see a colleague is already working on the issue :)

    Reply Upvote
  • Just wanted to post the final resolution of the ticket in case anyone else has a similar issue :)

    We only pull the UTM params off of the browser URL if you use device mode. Dave changed the connection mode from cloud to device and the issue was solved.

    Reply Upvote
  • Noted on the post above Monica Damborenea Maggie Chu - any sense of when UTMs will be supported in Cloud mode (e.g. lower priority or higher priority)? We're going to have roll our own solution, but rather painful and hurts the perception of Segment's value in our org

    Reply Upvote
  • Kyle Asano Luckily, our engineering team is, in fact, working on this feature improvement :)

    We have updated them with your request to try and get more visibility into timing from their side. But just to set expectations I suspect it'd be a while before we make changes. 
    I know that's probably not the answer you wanted to hear, but hopefully, it provides a bit more context.

    Reply Upvote
  • Any updates to this q?

    Reply Upvote 1
  • We tried to switch over to cloud mode about a year ago but had to roll back due to this issue - looping back here to see if this has been resolved?

    Reply Upvote
  • I found this does work; just was inadequately documented. 


    The third [options] parameter to page(), identify() and track() is formatted like:

    {campaign: {
        name: utm_campaign,
        source: utm_source,
        medium: utm_medium,
        term: utm_term,
        content: utm_content
    and utm are manually passed through. Doesn't happen automatic. 

    Reply Upvote