1

Data Inconsistency between GA & Intercom (Using Segment)

Hi!

I have an analytics inconsistency, which (potentially) makes me miss out on 50% of actionable conversions of high value on the platform I'm working on. So, for the obvious reasons, I want to get to the bottom of this. But I'm stuck in the troubleshooting...

I made a high-level graphic (see attached image) of (1) my setup, (2) the analytics flow, and (3) where the inconsistency is found.

- I was not able to find documentation, nor Q&A, that covers my case.
- The Segment app does not allow me to diagnose single events, because the conversions at hand are always flooded by other events, like PageViews. And since Segment does not store much, so I can't look backwards far enough.
- In point (3) we made sure the Identify is flushed before calling Track, so the Event should always be assigned to a User when it reaches Intercom.
- We recently added nr 3 and 5 and discovered the inconsistency. But so far, to the best of my knowledge, the setup is working well. Data from Intercom matches what I see on the website and the same holds true for Google Analytics. 

I would appreciate anyone that has an idea to put me in the right direction of understanding what is going wrong.

Thanks.

2replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • Hi David,

    Thank you very much for that wonderful graphic and for the context you provided. If you don't mind can you please resubmit this information in a support ticket. Workspace specific issues such as this are much better suited to be addressed through that support process. 

    Cheers,

    Reply Upvote
  • Thanks James. I submitted it.

    Reply Upvote